我是否必須刪除VS 2010 beta1以獲得在asp.net 2.0上運行的Web應用程序?

[英]Do I have to remove VS 2010 beta1 in order to get a web app to work on asp.net 2.0?


I think the title is enough :). I have VS 2010 beta1 installed, and I wish to run an asp.net mvc application on my local IIS. The problem is, the asp.net 4.0 runtime is selected by default for all the web sites, when I try to change it to asp.net 2.0, I get the following error message:
alt text http://img520.imageshack.us/img520/7946/iiserror.jpg

我認為標題就夠了:)。我安裝了VS 2010 beta1,我希望在我的本地IIS上運行asp.net mvc應用程序。問題是,默認情況下為所有網站選擇了asp.net 4.0運行時,當我嘗試將其更改為asp.net 2.0時,我收到以下錯誤消息:alt text http://img520.imageshack.us /img520/7946/iiserror.jpg

I click yes, then ok, and when I get back to the ASP.NET tab of my site's properties, I see the 4.0 version is selected back again! Do I have to remove VS 2010 in order to get this to work? (hopefully not)

我單擊是,然后確定,當我回到我網站的屬性的ASP.NET選項卡時,我看到再次選擇4.0版本!我是否必須刪除VS 2010才能使其正常工作? (希望不是)


Ps: I'm using windows XP and IIS 5.1

Ps:我正在使用Windows XP和IIS 5.1

1 个解决方案

#1


If you change the Default for your IIS it does not mean that it will change the value on all the sites. You will need to go change them individually back to 2.0

如果更改IIS的默認值,則並不意味着它將更改所有站點上的值。您需要將它們單獨更改回2.0


注意!

本站翻译的文章,版权归属于本站,未经许可禁止转摘,转摘请注明本文地址:https://www.itdaan.com/blog/2009/07/27/72a2585146bef7dfa684d85a0a1e4c2c.html



 
粤ICP备14056181号  © 2014-2020 ITdaan.com