ionic build Android錯誤記錄 error in opening zip file



0.寫在前頭

    運行 :cordova requirements

    Requirements check results for android:

    Java JDK: installed 1.8.0
    Android SDK: installed
    Android target: installed android-21,android-22,android-23,android-24,android-25
    Gradle: installed

 

    Requirements check results for ios:
    Apple OS X: installed darwin
    Xcode: installed 7.2
    ios-deploy: installed 1.9.0
    CocoaPods: not installed

可以檢查環境

1.try it 看看能不能正常運行

cordova -v
cordova create testing
cd testing
cordova plugin add cordova-plugin-sim
cordova platform add android
cordova build android
2.java -version 檢查java環境
3.error in opening zip file如果是這個錯誤,
大概是因為gradle文件太大,沒有下載完全,
http://downloads.gradle.org/distributions/gradle-2.13-all.zip重新下載到本地,
找到你之前下載的目錄,刪除gradle-2.13-all/7hsc6vr6mi3i6i5m7q9hj4ci1q/下的所有文件,copy剛下載的,
再嘗試ionic run android
4.如果是ionic插件的錯誤,可能和Android版本有關系,
嘗試 ionic platform rm android
   ionic platform add android@5.2.2帶上版本號
再 ionic run android

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
粤ICP备14056181号  © 2014-2020 ITdaan.com