解決maven項目install之后報出Perhaps you are running on a JRE rather than a JDK?錯誤


     不管在什么地方,什么時候,學習是快速提升自己的能力的一種體現!!!!!!!!!!!


前幾天安裝了新的eclipse,今天創建了一個maven項目測試下自己寫的代碼,結果 在install的時候報出了  No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK?(大概的意思就是:沒有提供編譯器的環境,可能你想運行的是一個JRE而不是一個JDK?==》進一步解釋就是我需要的是JDK而不是JRE)的錯誤




根據報錯提示意思於是想到了eclipse默認是運行JRE,可能大家都很少在eclipse配置過JDK(我是這樣的),所以就出現了maven項目install需要依賴JDK而不是JRE的錯誤


那如何解決呢?   請看下圖 





點擊Add之后彈出窗口選中箭頭所指,點擊Next



點擊Directory選擇JDK安裝位置








完成之后就可以重新install你的maven項目了,這時你就會發現SUCCESS了






如果此文章有什么不對的地方請路過的大神指出,以免誤人子弟


尊重原創,如要轉載請注明出處

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
粤ICP备14056181号  © 2014-2020 ITdaan.com