在Android Studio(Linux)中啟動時Android模擬器設備崩潰

[英]Android Emulator Device crash when start in Android Studio (Linux)


When I start that device it was crashed and show this error in the console of Android Studio:

當我啟動該設備時,它崩潰並在Android Studio的控制台中顯示此錯誤:

emulator64-arm: ../../../../../../../src/mesa/drivers/dri/i915/i915_fragprog.c:1225: i915BindProgram: Assertion `p->on_hardware == 0' failed.

emulator64-arm:../../../../../../../src/mesa/drivers/dri/i915/i915_fragprog.c:1225:i915BindProgram:斷言`p-> on_hardware = = 0'失敗。

When I use Genymotion it is disposed without any error notice.

當我使用Genymotion時,它沒有任何錯誤通知。

3 个解决方案

#1


9  

You need to Uncheck the "Use Host GPU" checkbox - in the emulator settings

您需要取消選中“使用主機GPU”復選框 - 在模擬器設置中

#2


9  

For emulator crashing seconds after launch in Android Studio 2.3.1 or later: Open Android Virtual Device Manager, select your AVD, select "Edit this AVD", in the new window (Virtual Device Configuration), goto Emulated Performance > Graphics and select the "Software (GLS)" option. This problem might be caused by: 1) Outdated graphics card drivers. 2) Older graphics cards, not properly supported by the generic Windows 8 (or newer) drivers.

對於在Android Studio 2.3.1或更高版本中啟動后模擬器崩潰幾秒鍾:打開Android虛擬設備管理器,選擇您的AVD,在新窗口中選擇“編輯此AVD”(虛擬設備配置),轉到模擬性能>圖形,然后選擇“軟件(GLS)”選項。此問題可能是由以下原因引起的:1)過時的圖形卡驅動程序。 2)較舊的圖形卡,通用Windows 8(或更新版本)驅動程序未正確支持。

#3


0  

I had this issue when I used my PC in combination with an USB docking station (DisplayLink). In this case you have to ensure to use the software emulation. Without the DisplayLink connection it works with GPU support as expected.

當我將我的電腦與USB擴展塢(DisplayLink)結合使用時,我遇到了這個問題。在這種情況下,您必須確保使用軟件模擬。如果沒有DisplayLink連接,它可以按預期使用GPU支持。


注意!

本站翻译的文章,版权归属于本站,未经许可禁止转摘,转摘请注明本文地址:https://www.itdaan.com/blog/2015/11/19/725e77b057c82a9762360a96ca954cf7.html



 
粤ICP备14056181号  © 2014-2021 ITdaan.com