Ubuntu 16.04 安裝eclipse svn插件


svn插件是協同開發軟件過程中的版本控制工具。Ubuntu下安裝后eclipse之后,選擇在線安裝。

1、打開安裝好的eclipse,選擇help,點擊install New Software...

2、在下面的窗口中鍵入http://subclipse.tigris.org/update_1.10.x, 回車檢索出Subclipse 和SVNKit,全部選中,注意要取消選擇Contact all update sites during install to find required software,不然安裝不了。

3、剩下就是一路默認點下去直到安裝完畢。

但是在使用中從svn服務器更新代碼時還是會報錯。安裝完Subclipse后重新啟動Eclipse,然后會彈出提示說svn插件需要JavaHL的支持,雖然可以忽略正常使用,但是

官網上,關於解決這個問題的信息很詳細,具體鏈接為http://subclipse.tigris.org/wiki/JavaHL#head-bb1dd50f9ec2f0d8c32246430c00e237d27a04fe;

基於Debian/Ubuntu的解決辦法是:  1、 在shell里運行$ apt-get install libsvn-java 2、修改eclipse.ini,添加如下內容:-Djava.library.path=/usr/lib/jni 3、需要注意的是一定要添加在-vmarg后面行。  

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



Ubuntu安裝Eclipse及SVN插件 Ubuntu下eclipse安裝svn插件 Ubuntu 16.04安裝Eclipse Ubuntu 16.04安裝Eclipse Eclipse安裝SVN插件 Eclipse 安裝 SVN 插件 eclipse安裝svn插件 Eclipse安裝SVN插件 eclipse 安裝svn插件 Eclipse安裝SVN插件
 
粤ICP备14056181号  © 2014-2021 ITdaan.com