eclipse下Drools5.1 開發環境搭建


一、下載開發工具: 因為Drools5.1提供的是eclipse3.5版之后的IDE開發工具,所以要求使用3.4版的eclipse.下載地址:http://eclipse.org。然后再到http://jboss.org/drools/downloads.html 下載Drools5 的 Eclipse 插件版 IDE (Drools Eclipse 3.5 Workbench,其中的3.5即為要求的eclipse版本)及 Drools5的開發工具包(Drools Binaries).下載完成后將二者都解壓到一個非中文目錄下。例如本例解壓到E:/eclipse下。然后在解壓完的drools-5.1.1-eclipse-all文件夾下新建eclipse文件夾,並將其它文件夾(features和plugins)移到新建的eclipse文件夾下。

 

二、安裝IDE:  打開 Eclipse 所在目錄下的 links 目錄(如果該目錄不存在可以手工在其目錄下創建一個 links目錄),在 links目錄下創建一個文本文件,並改名為 drools5-ide.link,用記事本打開該文件,按照下面的版本輸入 Drools5 Eclipse Plugin 文件所在目錄:path=E://eclipse//drools-5.1.1-eclipse-all。重新啟動eclipse,打開菜單 WindowPreferences,在彈出的窗口當中如果能在左邊導航樹中發現 Drools節點就表示Drools5 IDE 安裝成功了,如圖所示。

 

IDE 安裝完成后,接下來需要對 Drools 的 IDE 環境進行簡單的配置,在上面彈出的窗口當中選擇左邊導航樹菜單 DroolsInstalled  Drools Runtimes設置Drools  IDE 運行時依賴的開發工具包,點擊“Add…”按鈕添加一個開發工具包,將剛剛下載並解壓的drools-5.1.1-bin的目錄添加進來,並命名既可。 這樣就完成了整個drools的運行環境配置。

 


注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
粤ICP备14056181号  © 2014-2021 ITdaan.com