RAD Studio 10.3 Rio (BCB & Dephi) 發布啦


期盼已久的RAD Studio 10.3 Rio  終於發布了:

下載鏈接:http://altd.embarcadero.com/download/radstudio/10.3/delphicbuilder10_3_0_94364.iso

妖哥收藏了歷史版本:

博客鏈接:https://bbs.csdn.net/topics/392139957

來看看官方給的介紹:

http://docwiki.embarcadero.com/RADStudio/Rio/en/What%27s_New?tdsourcetag=s_pctim_aiomsg

1.Delphi Language

Inline Variable Declaration
The Delphi language in 10.3 has a fairly core change in the way it allows far more flexibility in the declaration of local variables. Until now, following classic Pascal language rules, all variable and constant declarations had to be done in a var or const block written before the beginning of a function, procedure or method code.

The new inline variable declaration syntax allows you to declare the variable or constant directly in the code and assign a value to it directly in the same statement. It is also possible to declare variables in a nested code block, with visibility and lifetime limited to that nested block.

Type inference
Variables declared inline also benefit from type inference. You do not need to specify a type for an inline variable with a direct assignment, as it can get inferred from the value assigned to it.

Traditional Memory Reference Counting in the Linux compiler
The Linux 64-bit compiler in 10.3 has been ‘reverted’ to using the non-ARC implementation of object memory management, matching exactly the Windows behavior.

The NEXTGEN define has been disabled for the Linux 64-bit compiler.

AnsiString / AnsiChar on Linux
RAD Studio 10.3 Rio has enabled support for the older-style AnsiChar/AnsiString data types on Linux. Use them with care, given Unicode is the preferred string type also on Linux and that Ansi code pages on Windows and Linux won’t match. However, this can help increase compatibility with existing low-level string management code.

 

2.C++

       1)編譯器的提升,C++11, C++14,C++17

       2)代碼模板

       3)默認Clang編譯器

       4)可以自己指定C++編譯器版本

 3.IDE界面

       1) 增加一套新的主題

4.Delphi and C++

5.VCL

        1)High DPI Image List Support

6.FireMonkey

         1)Android API level 26 or higher

7.iOS 12 support

8.Mojave support

9.FireDAC and Database
---------------------
作者:johnlaoxing
來源:CSDN
原文:https://blog.csdn.net/johnlaoxing/article/details/84333553
版權聲明:本文為博主原創文章,轉載請附上博文鏈接!


注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
粤ICP备14056181号  © 2014-2021 ITdaan.com