Xcode升級導致插件失效的解決辦法


升級XCode以后,插件無法加載

重新build,提示下面的錯誤

2016-04-02 10:13:17.152 Xcode[80853:843981] [MT] PluginLoading: Required plug-in compatibility UUIDACA8656B-FEA8-4B6D-8E4A-93F4C95C362C for plug-in at path '~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/VVDocumenter-Xcode.xcplugin' not present in DVTPlugInCompatibilityUUIDs


解決方法:

根據提示,打開目錄~/Library/Application Support/Developer/Shared/Xcode/Plug-ins找到VVDocumenter-Xcode.xcplugin 

右鍵顯示包內容,找到info.plist,打開編輯,找到 DVTPlugInCompatibilityUUIDs ,新增一項,把上面的UUID復制進去。


重新Build插件,關閉XCode,重新打開就會提示Load bundle了。


注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
粤ICP备14056181号  © 2014-2020 ITdaan.com