編譯opencv庫的注意事項


因為近一段時間,要使用opencv庫。我選用的是版本OpenCV-3.2.0(此時是20170603,此版本是最新版本)。我要使用里面的三維重建模塊,要調用VTK庫,不得已要親自編譯。這個是很簡單的,網上隨意就可搜到怎樣配置。只要打開with_vtk就可以了。

因為3版本opencv分為opencv和opencv_contrib兩部分,其中opencv是穩定版本,經過了大量測試,而opencv_contrib有很多最新的不穩定的模塊。后來添加opencv_contrib模塊時,在git中直接下了master分支,用cmake配置出現很大錯誤。糾結了很久,才明白要選擇tags里的對應版本才行。

通過這一階段的學習,明白了cmake的用法以及了解了很多編譯器的知識。



注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
粤ICP备14056181号  © 2014-2020 ITdaan.com