python 2.X与python 3.X共存


Python搭建非常简单,但是python有二本版本,python2和python3,但是由于一些python包用于2.X版本,而一些python包只能用于python 3.X的版本。对于我这种入门级菜鸟,如果想同时在一台电脑上即使用2.x 和3.X版本,就显得很无奈了。

我的电脑首先安装了python2.7
这次我想使用tensorflow,而tensorflow只能在python3.X下,所以我下载了python3.5的安装包,然后进行pip install tensorflow失败。

解决方案1(有时会有问题):
我把python3.5 安装目录下python.exe改成python3.exe
于是,两个版本的Python名称分别设置为:python和python3
使用 python -m pip install -U pip 进行升级的时候只是升级了2.7版本的pip
再使用 python3 -m pip install -U pip 对3.5版本pip进行升级,解决问题。

解决方案2:
先安装python2,python3,安装的时候添加环境到PATH

然后把python3安装目录下的python.exe改成python3.exe

删除python3\Scripts下的pip.exe

然后在CMD:
Pip –V (2.7的)
Pip3 –V (3.5的)
Python –V (2.7的)
Python3 –V (3.5的)

Note: python2.7下面的python2.7\Scripts下的pip.exe不能删除,不然pip2 –V报错。


注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
粤ICP备14056181号  © 2014-2020 ITdaan.com