PHP5.3.8连接Sql Server SQLSRV30


PHP5.3连接SQL Server就不能用php_mssql.dll了。

网上下载了好多都不行,因为它的版本是5.2的,不能再PHP5.3中使用。

后来听说微软专门为PHP出了自己的dll。

叫做Microsoft SQL Server Driver for PHP

PHP5.3中用3.0的版本就可以了。

SQLSRV30.EXE

就是这个玩意儿。

解压之后,有下面的文件产生。

我的PHP5.3.8用的就是上面圈出来的两个。恨死我了,我试了很多遍,终于找到合适的了。

在php.ini中加上

extension=php_pdo_sqlsrv_53_ts.dll
extension=php_sqlsrv_53_ts.dll 

然后重启apache就不会报错了,各种不兼容,各种缺少dll,烦死了。

不过问题终于解决了。还是很开心的。

下面就是如何使用扩展的问题了,继续探索吧!!!


注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
  © 2014-2022 ITdaan.com 联系我们: