android studio 的一个问题Error:Gradle version 2.2 is required. Current version is 2.14.1. If using the gr


已经开始用android staudio 一段时间了, 总是有这个那个的问题,谁叫咱们在ch呢, 今天遇到一个问题

Error:Gradle version 2.2 is required. Current version is 2.14.1. If using the gradle wrapper, try editing the distributionUrl in F:\git_workspace\DdTest\DbTest\gradle\wrapper\gradle-wrapper.properties to gradle-2.2-all.zip.


Please fix the project's Gradle settings.
<a href="fixGradleVersionInWrapper">Fix Gradle wrapper and re-import project</a><br><a href="openGradleSettings">Gradle settings</a>

明显是什么出问题了,好在android studio下面有一个解决方法,于是我点击了,结果就一直卡了,我关掉后,在来一次,还是出现现在这个样子,其实

我之前是改过那个2.14.1版本的,因为我本地没有2.2的版本,不改的话,就会一直去下载外国网上的东西,很浪费时间而且还不一定下好,改好后就可以用自己本地的那个版本了

,接着就出现我上文写到的那个问题了,我苦思冥想不得解,最后阴差阳错, 把在build.gradle下面的 

classpath 'com.android.tools.build:gradle:1.3.0' 改成我自己项目常用的 
classpath 'com.android.tools.build:gradle:2.0.0' 然后再tryAgain一下,居然好了,我也不知道什么原因,有知道的求告诉我一下原理哈

智能推荐

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
© 2014-2019 ITdaan.com 粤ICP备14056181号  

赞助商广告