php5.3.*编译出现make: *** [ext/gd/libgd/gd_compat.lo] Error 1的解决方法


转自VC错误:http://www.vcerror.com/?p=1881

问题描述:

升级系统,把php5.2.9升级到5.3.6,按照以前的编译参数,configure能正常通过,但是在make的时候提示:

In file included from /root/php-5.3.6/ext/gd/libgd/gd_compat.c:8:
/usr/local/jpeg/include/jpeglib.h:938: error: expected declaration specifiers or ‘...’ before ‘FILE’
/usr/local/jpeg/include/jpeglib.h:939: error: expected declaration specifiers or ‘...’ before ‘FILE’

make: *** [ext/gd/libgd/gd_compat.lo] Error 1

解决方法:
具体的解决方法参考文章:http://www.vcerror.com/?p=1881
智能推荐

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
© 2014-2019 ITdaan.com 粤ICP备14056181号  

赞助商广告