从Android模拟器连接到本地IIS ASP.NET站点的问题

[英]Issues Connecting to Local IIS ASP.NET site from Android Emulator


I have tried researching and tried some of the solution; however, I am not getting the connection to work. The purpose is to connect to a sample ASP.NET website called HelloHTML5 that would have an HTML file named "Home.html". From then on, I will edit the page accordingly.

我尝试过研究并尝试了一些解决方案;但是,我没有得到连接工作。目的是连接到一个名为HelloHTML5的示例ASP.NET网站,该网站将具有名为“Home.html”的HTML文件。从那时起,我将相应地编辑页面。

  • I am running VS 2013 in admin mode.
  • 我在管理模式下运行VS 2013。
  • Enabled all IIS features under "Programs and Features" as well as the separate IIS Hostable Web Core feature.
  • 启用“程序和功能”下的所有IIS功能以及单独的IIS Hostable Web Core功能。
  • Under the project's "Properties" within the "Web" tab under the "Servers" section I have it set to "Local IIS" which in turn displays the "Project URL" as so "http://localhost/HelloHTML5"(without quotations marks)
  • 在“服务器”部分下“Web”选项卡中的项目“属性”下,我将其设置为“本地IIS”,然后将“项目URL”显示为“http:// localhost / HelloHTML5”(不带引号)分数)
  • I have set "Home.html" as the start page.
  • 我已将“Home.html”设置为起始页面。

I can get the "Home.html" webpage to display on any web browser; however, I cannot get it to display on a Android Emulator.

我可以在任何网络浏览器上显示“Home.html”网页;但是,我无法在Android模拟器上显示它。

  • I am running the ADT version of Eclipse in admin mode and without.
  • 我在管理模式下运行Eclipse的ADT版本而没有。
  • I open the AVD Manager and start the emulator.
  • 我打开AVD Manager并启动模拟器。
  • The emulator loads to the home screen.
  • 模拟器加载到主屏幕。
  • Within the emulator browser I enter the given

    在模拟器浏览器中,我输入给定的

    1. The local ip address (IPv4): http://169.254.00.00/hellohtml5/home.html
    2. 本地IP地址(IPv4):http://169.254.00.00/hellohtml5/home.html
    3. http://169.254.00.00/hellohtml5/
    4. http://169.254.00.00/hellohtml5/
    5. http://169.254.00.00/hellohtml5
    6. http://169.254.00.00/hellohtml5
    7. Other variations as well
    8. 其他变化也是如此

Eventually I get the "Webpage not Available" message on the Android Emulator.

最终我在Android模拟器上收到“网页不可用”消息。

This is probably excessive information; however, for the sake of being specific:

这可能是过多的信息;但是,为了具体:

  1. I am running the webpage via VS 2013 by selecting view in "Google Chrome".
  2. 我通过选择“Google Chrome”中的视图,通过VS 2013运行网页。
  3. I am running an Android Emulator with API19.
  4. 我正在使用API​​19运行Android模拟器。

Please advice if any more information is needed to resolve this issue. Thanks in advance.

如果需要更多信息来解决此问题,请提供建议。提前致谢。

1 个解决方案

#1


0  

Have you tried connecting to http://10.0.2.2 ? See more here: http://developer.android.com/tools/devices/emulator.html#networkaddresses

您是否尝试过连接到http://10.0.2.2?在此处查看更多信息:http://developer.android.com/tools/devices/emulator.html#networkaddresses


注意!

本站翻译的文章,版权归属于本站,未经许可禁止转摘,转摘请注明本文地址:http://www.itdaan.com/blog/2014/09/25/d5b530f9f33ec855922d1aeef38d53e5.html



 
© 2014-2018 ITdaan.com 粤ICP备14056181号