If so, how?
When you go to http://rubyonrails.org/download, it says:
We recommend Ruby 1.8.7 for use with Rails. Ruby 1.8.6, 1.8.5, 1.8.4 and 1.8.2 are still usable too, but version 1.8.3 is not.
我们建议使用Ruby 1.8.7与Rails一起使用。 Ruby 1.8.6,1.8.5,1.8.4和1.8.2仍然可用,但1.8.3版本不可用。
Rails does work in 1.9 as of 2.3. I suppose they still recommend Ruby 1.8.7 because it has the most compatibility with other Ruby libraries — a lot of them are still catching up.
从2.3开始,Rails在1.9中工作。我认为他们仍然推荐Ruby 1.8.7,因为它与其他Ruby库的兼容性最高 - 其中很多仍然在追赶。
From the announcement of Rails 2.2:
Jeremy Kemper has been rocking on both Ruby 1.9 and JRuby compatibility. Rails 2.2 is fully compatible with both, but again, there might be supporting libraries and gems that are not. Again, lots of work is going into making everything else fully compatible as well.
Jeremy Kemper一直在摇摆Ruby 1.9和JRuby兼容性。 Rails 2.2与两者完全兼容,但同样,可能还有支持库和宝石。同样,许多工作也正在使其他一切完全兼容。
Then, from the release notes for Rails 2.3:
Rails 2.3 should pass all of its own tests whether you are running on Ruby 1.8 or the now-released Ruby 1.9.1. You should be aware, though, that moving to 1.9.1 entails checking all of the data adapters, plugins, and other code that you depend on for Ruby 1.9.1 compatibility, as well as Rails core.
无论您是在Ruby 1.8上运行还是在现在发布的Ruby 1.9.1上运行,Rails 2.3都应该通过它自己的所有测试。但是,您应该知道,迁移到1.9.1需要检查所有数据适配器,插件和其他依赖于Ruby 1.9.1兼容性的代码,以及Rails核心。
Based on their discussion board, Rails 2.3.0RC1 and later versions are compatible with Ruby 1.9.1 (and presumably, any later 1.9 versions). I'm guessing they haven't gotten aroudn to updating the site properly.
基于他们的讨论板,Rails 2.3.0RC1和更高版本与Ruby 1.9.1(可能是任何后来的1.9版本)兼容。我猜他们没有得到正确更新网站的aroudn。
Rspec has only recently been ported to 1.9, therefore many gems have not been able to run their test suites in 1.9 until recently, so many gems are not yet stable in 1.9